Nuxeo Platform User Documentation

Traceability

The History tab of a document gives you access to the audit trail of the document and its versions, thus ensuring the traceability of documents.

Audit Trail

All the actions that are done on documents are registered in the document's audit trail available from Event log sub tab, with several information, such as the date and time, the user, the comment, etc.

Archived Versions

The History tab also displays the previous versions of the document that were archived when the document was edited and its version increased. All previous versions can be consulted. You can also restore or delete archived versions. If you installed Nuxeo Diff you cal also compare two versions of the document.

Version number 0.0

Draft version 0.0 is not archived. See the page Editing Content for more information about versioning.

Archived versions have few actions available: you can only create relations from it to another document and subscribe to notifications.

All users can consult the previous versions of a document.

Restoring versions

You need to have "version", "edit" or "manage everything" permissions to restore a previous version of a document. Restoring an archived version means making it the current version of the document. The modifications done since that old version are thus not taken into account anymore.

When you restore a version by clicking the Restore button, the document is displayed as it was for the chosen version and has the same archived version's number. The next time it will be modified, its version number will automatically be increased.

For instance, your document's version is currently 0.3. When you click on the Restore button of the version 0.1, the Summary tab of the document is displayed: the content and metadata are the one of version 0.1, and the version number is 0.1. When the document is modified, the version number is automatically increased to 0.3+.

More about versioning and history in this documentation

We'd love to hear your thoughts!

All fields required