Nuxeo Core Developer Guide

Installing Dart and Related Tools

Updated: October 22, 2018 Page Information Edit on GitHub

See https://www.dartlang.org/install.

Installing Dart

Modules based on Dart require the version 1.23.x. Once installed, verify the version in a terminal:

$ pub version
Pub 1.23.0

Linux

Using APT:

sudo apt-get install apt-transport-https
sudo sh -c 'curl https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -'
sudo sh -c 'curl https://storage.googleapis.com/download.dartlang.org/linux/debian/dart_stable.list > /etc/apt/sources.list.d/dart_stable.list'
sudo apt-get update
sudo apt-get install dart=1.23.0-1

sudo update-alternatives --install /usr/bin/dart dart /usr/lib/dart/bin/dart 0
sudo update-alternatives --install /usr/bin/pub pub /usr/lib/dart/bin/pub 0
sudo update-alternatives --install /usr/bin/dart2js dart2js /usr/lib/dart/bin/dart2js 0

See https://www.dartlang.org/install/linux for other Linux install options.

OS X

Using Homebrew:

brew tap dart-lang/homebrew-dart
brew install https://raw.githubusercontent.com/dart-lang/homebrew-dart/b55507ab62b2e724b62e58a8e5363a726e34b7e7/dart.rb --with-dartium

See https://www.dartlang.org/install/mac for other Mac install options.

Windows

Using Chocolatey:

choco install dart-sdk -version 1.23.0
choco install dartium  -version 1.23.0

See https://www.dartlang.org/install/windows for other Windows install options.

Dart Tools

Dart plugins exist for many commonly used IDEs. See https://www.dartlang.org/tools.

2 months ago manonlumeau NXDOC-1650 fix about integrating changes, add mention on multiple attempts
2 years ago Solen Guitter 2
4 years ago Julien Carsique 1
History: Created by Julien Carsique

We'd love to hear your thoughts!

All fields required