Server

Compatibility Matrix

Updated: April 12, 2021

Java

Supported Java version: JDK 11 (Azul's Zulu OpenJDK or Oracle's JDK).

Databases

The Nuxeo Platform supports the following databases.

  • Recommended, validated by continuous integration:
    • MongoDB 4.4
    • PostgreSQL 13
  • Supported, not validated by continuous integration:
    • MongoDB 4.0 and 4.2
    • PostgreSQL 11 and 12
    • MariaDB 10.3
    • MySQL 8.0
    • Oracle 18c
    • SQL Server 2017

Notes

Nuxeo Platform will likely work with greater versions of the aforementioned databases. Do not hesitate to inform Nuxeo support of your attempts with different versions. More information can be found on the Database Configuration page.
Note that Nuxeo Server is shipped with an embedded H2 database, for quick evaluation purposes. One of the listed databases is required for a production set up or for a more thorough evaluation, like performance testing.

Application Servers

Nuxeo Platform can be based on Tomcat. The supported version is:

  • Tomcat 9.0.x

Nuxeo is shipped with an embedded Tomcat server.

Redis

Nuxeo Platform Version: LTS 2021 LTS 2019 LTS 2017 LTS 2016
Redis 2.8.x
3.0.x
3.2.x
4.0.x
5.0.x
6.0.x
2.8.x
3.0.x
3.2.x
4.0.x
2.8.x
3.0.x
3.2.x
4.0.x
2.8.x
3.0.x
3.2.x
4.0.x

More information can be found on the Nuxeo and Redis and Redis Configuration pages.

Elasticsearch

Nuxeo Platform Version: LTS 2021 LTS 2019 LTS 2017 LTS 2016
Elasticsearch Library: 7.9.2
Cluster: 7.7 to 7.9 RestClient protocol only.
Library: 6.5.3
Cluster:
  • 6.5.x to 6.8.x when using the RestClient protocol.
  • 6.5.x when using the TransportClient.
Library: 5.6.3
Cluster: 5.6.x
From 8.1 to 8.3:
Library: 1.5.2
Cluster: 1.5.2 to 1.7.x
From 8.10:
Library: 2.3.5
Cluster: 2.3.x to 2.4.x

More information can be found on the Elasticsearch Setup page.

Kafka

Nuxeo Platform Version: LTS 2021 LTS 2019 LTS 2017
Kafka Library: 2.6.0 scala 2.12
Cluster: 1.x, 2.x
Library: 2.1.1 scala 2.12 since HF15
Library: 2.1.0 scala 2.12 from HF01 to HF14
Cluster: 1.x, 2.x
Library: 1.0.0 scala 2.11
Cluster: 1.x, 2.0.0

Kafka supports backward and forward compatibility a cluster >= 1.0.0 works, we still advice to use the latest available stable version.

Browsers

Depending on the user interface addon or applications you use, the browser requirements can differ. See the relevant pages:

We'd love to hear your thoughts!

All fields required